Square Coins(HDU-1398)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u011815404/article/details/89887363

Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins, 
one 4-credit coin and six 1-credit coins, 
two 4-credit coins and two 1-credit coins, and 
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland. 

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300. 

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 

Sample Input

2
10
30
0

Sample Output

1
4
27

题意:现在有 17 种硬币种类,其值为:1^2,2^2,3^2,4^2...17^2,现在输入一个数 n,问能够组合成 n 的组合有多少种

思路:普通母函数

根据题意,首先可以得出 k=17,数组 v[i]=i*i,n1[i]=0,n2[i]=INF,因此,内循环的 j<=n2[i] 可以省略

此外,由题意 P=n

最后修改模版套用即可

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define EPS 1e-9
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LL long long
const int MOD = 1E9+7;
const int N = 10000+5;
const int dx[] = {0,0,-1,1,-1,-1,1,1};
const int dy[] = {-1,1,0,0,-1,1,-1,1};
using namespace std;

int a[N];//权重为i的组合数
int b[N];//临时数组
int P;//最大指数
int v[N],n1[N],n2[N];
void cal(int k){
    memset(a,0,sizeof(a));
    a[0]=1;
    for(int i=1;i<=k;i++){//循环每个因子
        memset(b,0,sizeof(b));
        for(int j=n1[i];j*v[i]<=P;j++)//循环每个因子的每一项,n2是无穷,去掉原有的j<=n2[i]
            for(int k=0;k+j*v[i]<=P;k++)//循环a的每个项
                b[k+j*v[i]]+=a[k];//把结果加到对应位
        memcpy(a,b,sizeof(b));//b赋值给a
    }
}
int main(){
    for(int i=1;i<=17;i++)
        v[i]=i*i;
    int n;
    while(scanf("%d",&n)!=EOF&&n){
        memset(n1,0,sizeof(n1));
        P=n;
        cal(17);
        printf("%d\n",a[P]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/u011815404/article/details/89887363