c 最大值Max Num

Problem Description
There are some students in a class, Can you help teacher find the highest student .

Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.

Output
For each case output the highest height, the height to two decimal plases;

Sample Input
2
3 170.00 165.00 180.00
4 165.00 182.00 172.00 160.00

Sample Output
180.00
182.00

#include<stdio.h>
void main()
{
    int n,i,j,t;
	double high,max;
    while(scanf("%d",&t)!=EOF)
    {
        for(i=0;i<t;i++){
			max = 0;
			scanf("%d",&n);
			for(j=0;j<n;j++){
			    scanf("%lf",&high);
			    if(high>max){
			        max = high;
				}
			}
			printf("%.2lf\n",max);
		}	
    }
}


猜你喜欢

转载自blog.csdn.net/qq_40811682/article/details/88342863
num