HDUOJ2044:一只小蜜蜂...

版权声明:qq836678589 https://blog.csdn.net/weixin_43924623/article/details/91391023

一只小蜜蜂…

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 111122 Accepted Submission(s): 39257

Problem Description
有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。

在这里插入图片描述

Input
输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。

Output
对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。

Sample Input
2
1 2
3 6

Sample Output
1
3

#include<iostream>
using namespace std;
int main(){
	int n,a,b;
	long long  ar[51]={0,1,2,3};
	for(int i=4;i<=50;i++)
		ar[i]=ar[i-1]+ar[i-2];
	cin>>n;
	while(n--){
		cin>>a>>b;
		cout<<ar[b-a]<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43924623/article/details/91391023