Josephina and RPG ZOJ - 3735

 Josephina and RPG ZOJ - 3735

A role-playing game (RPG and sometimes roleplaying game) is a game in which players assume the roles of characters in a fictional setting. Players take responsibility for acting out these roles within a narrative, either through literal acting or through a process of structured decision-making or character development.

Recently, Josephina is busy playing a RPG named TX3. In this game, M characters are available to by selected by players. In the whole game, Josephina is most interested in the "Challenge Game" part.

The Challenge Game is a team play game. A challenger team is made up of three players, and the three characters used by players in the team are required to be different. At the beginning of the Challenge Game, the players can choose any characters combination as the start team. Then, they will fight with N AI teams one after another. There is a special rule in the Challenge Game: once the challenger team beat an AI team, they have a chance to change the current characters combination with the AI team. Anyway, the challenger team can insist on using the current team and ignore the exchange opportunity. Note that the players can only change the characters combination to the latest defeated AI team. The challenger team get victory only if they beat all the AI teams.

Josephina is good at statistics, and she writes a table to record the winning rate between all different character combinations. She wants to know the maximum winning probability if she always chooses best strategy in the game. Can you help her?

Input

There are multiple test cases. The first line of each test case is an integer M (3 ≤ M ≤ 10), which indicates the number of characters. The following is a matrix Twhose size is R × RR equals to C(M, 3). T(i, j) indicates the winning rate of team i when it is faced with team j. We guarantee that T(i, j) + T(j, i) = 1.0. All winning rates will retain two decimal places. An integer N (1 ≤ N ≤ 10000) is given next, which indicates the number of AI teams. The following line contains Nintegers which are the IDs (0-based) of the AI teams. The IDs can be duplicated.

<h4< dd="">Output

For each test case, please output the maximum winning probability if Josephina uses the best strategy in the game. For each answer, an absolute error not more than 1e-6 is acceptable.

<h4< dd="">Sample Input

4
0.50 0.50 0.20 0.30
0.50 0.50 0.90 0.40
0.80 0.10 0.50 0.60
0.70 0.60 0.40 0.50
3
0 1 2

<h4< dd="">Sample Output

0.378000



题意:m个角色组成C(M, 3)支队伍,N个对手,刚开始可以任选一支队伍作为自己的队,打败一支队伍后可以选择打败
的这支队伍作为自己的队,继续作战,求打败所有队伍的最大概率。

分析:

那么转移方程就是:

d[i][j]=max(dp(i,j+1)*mat[i][team[j+1]],dp(team[j],j+1)*mat[team[j]][team[j+1]]); 

//mat[i][j]是i打j的胜率,team就是那n个队

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MAXN 10000+10
#define INF 1<<30
int vis[125][MAXN] = {0};
double d[125][MAXN];
double mat[200][200];
int team[MAXN];
int m,n;
double dp(int i,int j) {
    if(j==m-1||i>=n||i<0)
        return 1;
    if(vis[i][j])
        return d[i][j];
    vis[i][j]=1;
    d[i][j]=max(dp(i,j+1)*mat[i][team[j+1]],dp(team[j],j+1)*mat[team[j]][team[j+1]]);
    return d[i][j];
}
int main () {
    int r[20]= {0,0,0,1,4,10,20,35,56,84,120};
    while(scanf("%d",&n)!=EOF) {
        n=r[n];
        memset(vis,0,sizeof(vis));
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                scanf("%lf",&mat[i][j]);
        scanf("%d",&m);
        for(int i = 0; i<m; i++)
            scanf("%d",&team[i]);
        double ans=-1;
        for(int i=0; i<n; i++) {
            ans=max(ans,dp(i,0)*mat[i][team[0]]);
        }
        printf("%lf\n",ans);
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/geraldg/p/11253329.html
RPG
ZOJ