浙大数据结构课后习题 练习二 7-3 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO



#include <iostream>
#include <stack>
using namespace std;
int main(){
    //最大容量,一行最大数,n行
    int maxCapacity,maxNum,line;
    cin>>maxCapacity>>maxNum>>line;
    while(line--){
        stack<int> sta;
        int val[maxNum];int a=0;
        for(int i=0;i<maxNum;i++){
            cin>>val[i];
        }
        bool no=false;
        for(int i=0;i<maxNum;i++){
            sta.push(i+1);
            if(sta.size()>maxCapacity){
                no=true;
                break;
            }
            while(!sta.empty()&&val[a]==sta.top()){
                sta.pop();
                a++;
            }
        }
        if(no) cout<<"NO"<<endl;
        else if(sta.empty()) cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    system("pause");
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/littlepage/p/11375366.html