hdu 3746 Cyclic Nacklace(kmp)

 CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

这里写图片描述
Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~’z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).
Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

题目描述:为让该手链是可以由循环的珠串构成,求我们最少需要在往已经构成的珠串后添加多少个珠子。。。所以这道题是让我们求最小循环节的的长度,看这个字符串是否能由该循环节周期性表示,不行的话就用循环节的长度减去不满足循环的长度就得出我们需要的答案。。。

循环节长度:s = strlen(a) - next[strlen(a)];

注意:若循环节长度为strlen(a),那么说明我们需要添加strlen(a)长度的珠子才能构成两个循环~即输出strlen(a)

#include<cstdio>
#include<cstring>
using namespace std;

char a[100010];
int ne[100010];

void getnext(){
    int l = strlen(a);
    int i = 0, j = -1;
    ne[0] = -1;
    while(i < l){
        if(j == -1 || a[i] == a[j]){
            ne[++i] = ++j;
        }
        else j = ne[j];
    }
}

int main(){
    int t, s;
    scanf("%d", &t);
    while(t--){
        scanf("%s", &a);
        getnext();
        int len = strlen(a);
        s = len - ne[len];//求最小循环节的长度
        if(len % s == 0 && len != s)
            printf("0\n");
        else{
            printf("%d\n", s - ne[len]%s);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ling_wang/article/details/80156940
今日推荐