算法 安迪的第一个字典 UVa10815,set回顾

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/qq_43269048/article/details/99700934

题目

题目跳转:UVa10815
Andy, 8, has a dream - he wants to produce his
very own dictionary. This is not an easy task for
him, as the number of words that he knows is,
well, not quite enough. Instead of thinking up all
the words himself, he has a briliant idea. From
his bookshelf he would pick one of his favourite
story books, from which he would copy out all
the distinct words. By arranging the words in
alphabetical order, he is done! Of course, it is
a really time-consuming job, and this is where a
computer program is helpful.
You are asked to write a program that lists
all the different words in the input text. In this
problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case.
Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same.
Input
The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input
is terminated by EOF.
Output
Your output should give a list of different words that appears in the input text, one in a line. The
words should all be in lower case, sorted in alphabetical order. You can be sure that he number of
distinct words in the text does not exceed 5000.
Sample Input
Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: “Disneyland Left.”
So they went home.
Sample Output
a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they

解题思路:直接使用C++STL中的Set容器,根据set中元素已从小到大排好顺序这一性质,用一个for循环即可从小到大遍历所有元素,输入时把所有非字母的字符转化为空格,然后利用stringstream得到各个单词,再用迭代器将其输出

#include <iostream>
#include <cstdio>
#include <set>
#include <sstream>
using namespace std;
set<string> dict;//string集合 
int main()
{
	string s,buf;
	while(cin>>s){
		for(int i=0;i<s.length();i++){
			if(isalpha(s[i])) s[i]=tolower(s[i]);
			else s[i]=' ';
		}
		stringstream ss(s);
		while(ss>>buf) dict.insert(buf);
	} 
	for(set<string>::iterator it=dict.begin();it!=dict.end();++it)
	cout<<*it<<"\n";
	return 0;
} 

学到的知识点:

  1. <sstream的>用法,在本题中通过将非字母字符转换为空格,利用ss>>but 判断是string还是空格或者换行符,如果是string类型的,则利用dict.insert(buf)方法将其加入set中
  2. 迭代器iterator的用法
  3. set中的元素自动排序, set,顾名思义是“集合”的意思,在set中元素都是唯一的,而且默认情况下会对元素自动进行升序排列,支持集合的交(set_intersection),差(set_difference) 并(set_union),对称差(set_symmetric_difference) 等一些集合上的操作,如果需要集合中的元素允许重复那么可以使用multiset。

猜你喜欢

转载自blog.csdn.net/qq_43269048/article/details/99700934