PAT 甲级 1068 Find More Coins (30 分) (dp,01背包问题记录最佳选择方案)***

1068 Find More Coins (30 分)
 

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 1 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤, the total number of coins) and M (≤, the amount of money Eva has to pay). The second line contains Nface values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V1​​V2​​Vk​​ such that V1​​+V2​​++Vk​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3 

Sample Output 2:

No Solution

题意:

用n个硬币买价值为m的东西,输出使用方案,使得正好几个硬币加起来价值为m。从小到大排列,输出最小的那个排列方案

题解:

  这是一道01背包问题,解题时注意题意的转化:

  • 可以将每个coin都看成value和weight都相同的物品
  • 要求所付的钱刚刚好,相当于要求背包必须刚好塞满,且价值最大。(限制背包体积相当于限制coin的总和不能超过所要付的钱,在此条件下求coin组合的最大值,如果这个最大值刚好等于要付的钱,则有解,此时背包也刚好处于塞满状态,否则无解)
  • 最后要求从小到大输出coin的组合,且有多解时输出最小的组合。这是此题的难点所在,我们应该将coin从大到小排序,在放进背包时也从大到小逐个检查物品,更新背包价值的条件是在加入一个新的物品后,价值>=原价值,注意此时等号的意义,由于物品是从大到小排序的,如果一个新的物品的加入可以保证价值和原来相同,则此时一定是发现了更小的组合。
  作者:cheerss
  链接:https://www.jianshu.com/p/20dac38241a5
  来源:简书
  著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。
 
  想到了背包和dp,但是一时间忘记怎么记录路径了。。。只好看别人的了,以后要回来回顾一下。。。。用数组标记的方式记录选择路径。
  问题的难点在于输出最小序列,一开始从小到大排了,原来应该从大到小排。因为先输出的是最后选的,越到后面选择越是小的。
 

AC代码:

#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
int dp[101];//bags[i]面值不大于i的最大的面值和
bool choice[10001][101];
int cmp(int a, int b){return a > b;}
int main(){
    int w[10001];
    int n,m;
    cin>>n>>m;
    for(int i=1;i<=n;i++){
        cin>>w[i];
    }
    sort(w+1,w+1+n,cmp);
    for(int i=1;i<=n;i++){
        for(int j=m;j>=w[i];j--){ //之所以要反着来,和背包问题的更新规则有关
            if(dp[j-w[i]]+w[i]>=dp[j]){//等号必须取到,否则输出的解是最大的sequence
                choice[i][j]=true;//跟踪哪个物品被选择了
                dp[j]=dp[j-w[i]]+w[i];
            }
        }
    }
    if(dp[m] != m) printf("No Solution");
    else{  //下面是输出最优组合的过程,其实和背包问题的更新规则有关,就是沿着选出解的路径,反着走回去,就找到了所有被选择的数字。
        int i=n,j=m;
        while(1){
            if(choice[i][j]==true){
                cout<<w[i];
                j-=w[i];
                if(j!=0) cout<<" ";
            }
            i--;
            if(j==0||i==0) break;
        }
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/caiyishuai/p/11762267.html