HDU An Easy Task

An Easy Task

时间限制: 1000ms
内存限制: 32768KB
HDU       ID: 1076
64位整型:      Java 类名:

题目描述

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.
 

输入

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
 

输出

For each test case, you should output the Nth leap year from year Y.
 

样例输入

3
2005 25
1855 12
2004 10000

样例输出

2108
1904
43236

提示

We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
 

#include <iostream>
using namespace std;

bool leapYear(int y)
{
if((y%4==0&&y%100!=0)||y%400==0)
return true;
return false;
}

int main()
{
int t;
cin>>t;
while(t--)
{
int y,n;
cin>>y>>n;
for(int i=0;i<n;)
if(leapYear(y))
{
i++;
y++;
}
else
y++;
cout<<y-1<<endl;
}
return 0;
}

猜你喜欢

转载自www.cnblogs.com/tianzeng/p/9035513.html