简单搜索 红与黑:

简单搜索 红与黑:

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

注:我英文不好自行翻译;

开个玩笑。

题目描述:

有一个长方形的房间,上面铺着方砖。每个瓷砖都是红色或黑色的。一个男人站在一块黑色的瓷砖上。从一个瓷砖,他可以移动到四个相邻瓷砖之一。但他不能在红瓦上移动,只能在黑瓦上移动。

编写一个程序,通过重复上述动作来计算他可以达到的黑色瓷砖的数量。

输入由多个数据集组成。数据集以包含两个正整数W和H的行开头;W和H分别是x和y方向上的平铺数。W和H不超过20。

数据集中还有H行,每行包含W个字符。每个字符代表一个瓷砖的颜色,如下所示。

'.'-一块黑色的瓷砖

“35;”-红色瓷砖

“@”-一个站在黑色瓷砖上的人(在数据集中只出现一次)

对于每个数据集,您的程序应该输出一行,其中包含他可以从初始平铺(包括其本身)到达的平铺数。

话不多说上代码:

#include<iostream>
#include<cstring>//听说不能用万能头?
using namespace std;//这不用解释
char f[501][501];//存瓷砖的“地图”
int ans,flag;
int n=-1,m=-1;//只是定义变量
void dfs(int x,int y)//核心
{
if(x<0 || y<0 || x>n || y>m)//判断有没有越界
return;//越界了就再见
f[x][y]='*';//走过的砖子不再走
if(f[x][y+1]=='.') ans++,dfs(x,y+1);//看看能不能走,能走就走一步;(向上)
if(f[x][y-1]=='.') ans++,dfs(x,y-1);//看看能不能走,能走就走一步;(向下)
if(f[x+1][y]=='.') ans++,dfs(x+1,y);//看看能不能走,能走就走一步;(向右)
if(f[x-1][y]=='.') ans++,dfs(x-1,y);//看看能不能走,能走就走一步;(向左)
}
int main()
{
while(cin>>m>>n)//因为有多组数据
{
memset(f,0,sizeof(f));//f数组初始化
ans=1,flag=0;//接着初始化
if(n==0 && m==0) return 0;//不要问我为什么,看题!
for(int i=1;i<=n;i++)//一个for循环
{
for(int j=1; j<=m; j++)//两个for循环
{
cin>>f[i][j];//读入地图
}
}
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)//循环一下找到那个男子的位置
{
if(f[i][j]=='@')//判断是否在上面
{
dfs(i,j);//走一走,活到九十九!
flag=1;//准备退出;
break;//第一次退出;
}
}
if (flag==1) break;//第二次退出。
}
cout<<ans<<endl;//输出。
}
return 0;//完美
}

猜你喜欢

转载自www.cnblogs.com/WWWZZZQQQ/p/12042247.html