hdu2102

A计划

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27680    Accepted Submission(s): 6940


Problem Description
可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。
 

Input
输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小N*M(1 <= N,M <=10)。T如上所意。接下去的前N*M表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。
 

Output
如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。
 

Sample Input
 
  
1 5 5 14 S*#*. .#... ..... ****. ...#. ..*.P #.*.. ***.. ...*. *.#..
 

Sample Output
 
  
YES
 

Source

注意的点
起点是固定的  
当走到传送门时  另一层的相对位置不能是墙或者传送门
还有就是可以从2层到1层  不一定是 只有 1层到2层
当变层时  记得都要置为访问过  变层时时间不变
#include<bits/stdc++.h>
using namespace std;
const int maxn = 15;
const int inf = 0x3f3f3f3f;
struct node{
	int x, y, z;
	int step;
	node(){
	}
	node(int x,int y,int z,int step)
	{
		this->x = x;
		this->y = y;
		this->z = z;
		this->step = step;
	}
};
char mp[3][maxn][maxn];
int visit[3][maxn][maxn];
int dir[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
int n, m, Time;
int px, py;
bool res;
void bfs()
{
	queue<node> q;
	q.push(node(1,1,0,0));
	visit[0][1][1] = 1;
	while(!q.empty())
	{
		node t = q.front();
		q.pop();
		if(t.step > Time)
		{
			//cout << t.step << endl;
		 	return ; 
		} 
		if(mp[t.z][t.x][t.y] == 'P')
		{
			res = true;
		//	cout << t.step << endl;
			return ;
		}
		
		for(int i = 0;i < 4;i ++)
		{
			int dx = t.x + dir[i][0];
			int dy = t.y + dir[i][1];
			int dz = t.z ;
			
			if(dx < 1 || dy < 1 || dx > n || dy > m || visit[dz][dx][dy] || mp[dz][dx][dy] == '*') continue;
		
			if(mp[dz][dx][dy] == '#' && (mp[!dz][dx][dy] == '*' || mp[!dz][dx][dy] == '#')) continue;
			
			if(mp[dz][dx][dy] == '#')
			{
				visit[dz][dx][dy] = 1;
				dz = !dz;
			}
			int dstep = t.step + 1;
			
			visit[dz][dx][dy] = 1;
			q.push(node(dx,dy,dz,dstep));
		}
	}
}

int main()
{
	int c;
	cin >> c;
	while(c --)
	{
		res = false;
		memset(visit,0,sizeof(visit));
		cin >> n >> m >> Time;
		for(int i = 1;i <= n;i ++)
		{
			for(int j = 1;j <= m;j ++)
			{
				cin >> mp[0][i][j];
			}
		}
		
		for(int i = 1;i <= n;i ++)
		{
			for(int j = 1;j <= m;j ++)
			{
				cin >> mp[1][i][j];
				if(mp[1][i][j] == 'P')
				{
					px = i;
					py = j;
				}
			}
		}
		bfs();
		if(res)
		cout << "YES" << endl;
		else
		cout << "NO" << endl;
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/soul_97/article/details/80217605