Tian Ji -- The Horse Racing(田忌赛马)/贪心算法

Tian Ji – The Horse Racing(田忌赛马)

田忌赛马的故事
(可以直接看题)
Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”
在这里插入图片描述
Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output

200
0
0

思路:
1、先从田忌的最差的马和齐王的最差的马比,如果田忌的马速度大于齐王的马赢一把。
2、如果田忌的最差的马比齐王最差的马还菜,让田忌的最差马拼掉齐王最好的马。
3、如果田忌的最差的马比齐王最差的马一样速度,则比较田忌最好的马和齐王最好的马:
① 如果田忌最好的马比齐王最好的马快,赢一把。
②如果田忌最差的马比齐王最好的马慢,让田忌最差的马和齐王最好的马比,输一把,一换一。
③如果田忌的最好的马和齐王的最好的马一样快。让田忌最差的马把齐王的最好的马比,输一把,一换一。
AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int a[10050];    //田忌的马
int b[10050];    //齐王的马
int main()
{
    int n;
    while(~scanf("%d",&n))	//多组输入
    {
        int win=0,lost=0,s=n,e=0;
        int sum=0;
        if(n==0)	//题目要求输入0,退出程序
        {
            break;
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&b[i]);
        }
        //把马的速度排序
        sort(a,a+n);
        sort(b,b+n);
        for(int i=0;i<n;i++)
        {
            for(int j=e;j<s;j++)
            {
                if(a[i]<b[j])   //田忌最慢的马比齐王最慢的慢
                {
                    lost++;     //败场加一
                    s--;
                    break;       //跳出循环再次比较
                }
                else if(a[i]>b[j])  //田忌最慢的马比齐王最慢的快
                {
                    win++;          //胜场加一
                    e++;
                    break;          //跳出循环再次比较
                }
                else        //田忌最慢的马和齐王最慢的马速度一样
                {
                    if(a[n-1]<b[s-1])   //田忌最好的马速度小于齐王最好的马
                    {
                        lost++; //败场加一
                        s--;
                        break;
                    }
                    else if(a[n-1]==b[s-1])
                    {
                        if(a[i]<b[s-1])    //田忌最慢的马和齐王最好的比
                        {
                            lost++;     //败场加一
                            s--;
                            break;
                        }
                        else    //顶多可以相等大于是不可能了
                        {
                            s--;
                            break;
                        }
                    }
                    else             //田忌最好的马比齐王的快
                    {
                        win++;  //胜场加一
                        s--;
                        n--;
                        i--;
                        break;
                    }
                }
            }
        }
        sum=(win-lost)*200;
        printf("%d\n",sum);
    }
    return 0;
}
发布了33 篇原创文章 · 获赞 35 · 访问量 1291

猜你喜欢

转载自blog.csdn.net/qq_45856289/article/details/103203988