HDU-1048,The Hardest Problem Ever(字符串处理)

Problem Description:

Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked.
You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite:

Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case. 

Input: 

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.

A single data set has 3 components:

Start line - A single line, "START"

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar

End line - A single line, "END"

Following the final data set will be a single line, "ENDOFINPUT". 

Output: 

For each data set, there will be exactly one line of output. This is the original message by Caesar. 

Sample Input: 

START

NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX

END

START

N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ

END

START

IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ

END

ENDOFINPUT 

Sample Output: 

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES

I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME

DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE 

解题思路:

这道题就是说每组数据都是三行 ,从START开始,END结束,对26个英文字母进行处理,每一个字母都向前移动5个,一定要记住ASCII码,其中A到E是特殊情况,向前移动5个等于向后移动21个,其他21个字母均为正常情况。 

程序代码: 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int main()
{
	string str,start,end;
	while(getline(cin,start))
	{
		if(start=="START")
			getline(cin,str);
		if(start=="ENDOFINPUT")
			break;
		for(int i=0;i<str.length();i++)
		{
			if(str[i]>='A'&&str[i]<='Z')
			{
				if(str[i]>='A'&&str[i]<='E')
					str[i]+=21;
				else
					str[i]-=5;
			}
		}
		getline(cin,end);
		if(end=="END")
		{
			for(int i=0;i<str.length();i++)
				cout<<str[i];
			cout<<endl;
		}
	}
	return 0;
}
发布了268 篇原创文章 · 获赞 276 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/weixin_43823808/article/details/104051658