4.1排序

今天开始继续算法笔记的学习,也算是复习一下之前学的内容。主要回顾了一下算法笔记的排序方面的内容,再总结一下排序的一些常用的方法。

4.1排序

4.1.1选择排序

一种非常基础的排序方式,就是重复将一个序列A中的最小值取出来,放入到另一个序列B中。

4.1.2插入排序

将序列A中的数一个个放入序列B中,放入的过程中进行排序。

这两种方法可以这样理解,一个是排好序再放入,一个是先放入再排序。

4.1.3sort函数

sort就是排序函数
需要有

 #include<algorithm>
    using namespce std;

函数调用格式 sort(a,a+n,cmp);

cmp也需要定义:bool cmp(student a,student b)

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

我是先完成一个测试点的排序,再进行拓展,延伸到多个测试点的情况

主要有个技巧,就是用num来作为所有测试人的数量,并用num与单个测试点人数的关系来进行排序,这样就会简单的多。

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

struct student{     //定义合适的学生信息结构体
    char registration_number[14];
    int final_rank;
    int score;
    int location_number;
    int local_rank;
}stu[30010];

bool cmp(student a,student b)
{
    if(a.score!=b.score) return a.score>b.score;
    else return strcmp(a.registration_number,b.registration_number)<0;
}

int main()
{
    int N,K,num=0;        //N和K分别为测试点数量,和单个地点的测试者数量,num为总考生人数
    int i,j;
    scanf("%d",&N);
    for(i=0;i<N;i++)
    {
        scanf("%d",&K);
        for(j=0;j<K;j++)        //读入测试者的个人信息
        {
            scanf("%s %d",stu[num].registration_number,&stu[num].score);
            stu[num].location_number=i+1;
            num++;
        }
        sort(stu+num-K,stu+num,cmp);
        stu[num-K].local_rank=1;
        for(int k=1;k<K;k++)        //单个测试点进行排序
        {
            if(stu[num-K+k].score==stu[num-K+k-1].score)stu[num-K+k].local_rank=stu[num-K+k-1].local_rank;
            else stu[num-K+k].local_rank=num-K+k+1-(num-K);
        }
    }
    sort(stu,stu+num,cmp);
    stu[0].final_rank=1;
    for(int k=1;k<num;k++)        //单个测试点进行排序
    {
        if(stu[k].score==stu[k-1].score)stu[k].final_rank=stu[k-1].final_rank;
        else stu[k].final_rank=k+1;
    }
    printf("%d\n",num);
    for(int j=0;j<num;j++)
    {
        printf("%s %d %d %d\n",stu[j].registration_number,stu[j].final_rank,stu[j].location_number,stu[j].local_rank);
    }
    return 0;
}
发布了24 篇原创文章 · 获赞 6 · 访问量 473

猜你喜欢

转载自blog.csdn.net/qq_39965800/article/details/90450411
今日推荐