【PAT】A1151 LCA in a Binary Tree (30point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 1000 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1151 LCA in a Binary Tree (30point(s))

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;
struct NODE{
    int data;
    struct NODE *lchild,*rchild;
};
vector<int> in,pre;
unordered_map<int,int> appr;
NODE *build(int preL,int preR,int inL,int inR){
    if(preL>preR)   return NULL;
    NODE *root=new NODE;
    root->data=pre[preL];
    appr[root->data]=1;
    int i;
    for(i=inL;i<=inR;i++){
        if(pre[preL]==in[i])
            break;
    }
    int lcnt=i-inL;
    root->lchild=build(preL+1,preL+lcnt,inL,i-1);
    root->rchild=build(preL+lcnt+1,preR,i+1,inR);
    return root;
}
NODE *LCA(NODE *root,int u,int v){		// 查找两结点的最低公共祖先
    if(root==NULL)  return NULL;
    if(root->data==u||root->data==v)    return root;
    NODE *l=LCA(root->lchild,u,v);
    NODE *r=LCA(root->rchild,u,v);
    if(l!=NULL&&r!=NULL)    return root;	// u,v分别位于左右子树的情况
    else if(l!=NULL)    return l;	// 在该结点的左子树
    else if(r!=NULL)    return r;	// 在该结点的右子树
}
int main(){
    int n,m,u,v;
    cin>>m>>n;
    pre.resize(n+1);
    in.resize(n+1);
    for(int i=1;i<=n;i++)   cin>>in[i];;
    for(int i=1;i<=n;i++)   cin>>pre[i];
    NODE *root=build(1,n,1,n);
    for(int i=0;i<m;i++){
        cin>>u>>v;
        if(appr[u]!=1&&appr[v]!=1)  printf("ERROR: %d and %d are not found.\n",u,v);
        else if(appr[u]!=1) printf("ERROR: %d is not found.\n",u);
        else if(appr[v]!=1) printf("ERROR: %d is not found.\n",v);
        else{
            NODE *temp=LCA(root,u,v);
            if(temp->data==u)   printf("%d is an ancestor of %d.\n",u,v);
            else if(temp->data==v)  printf("%d is an ancestor of %d.\n",v,u);
            else    printf("LCA of %d and %d is %d.\n",u,v,temp->data);
        }
    }
    return 0;
}

Analysis

-已知一棵二叉树的中序和前序。和M组两个结点。

-求每一组中,两个结点的最低公共祖先。

-可以说和A1143是一道题了。

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103812981
今日推荐