HDU 2.1.7 Leftmost Digit

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the leftmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
2
2

<div style="" font-size:="" 14px;="" border-top:="" #b7cbff="" 1px="" dashed;="" font-family:="" times"="">
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 
Author
Ignatius.L
#include<stdio.h>  
#include"algorithm"  
using namespace std;  
int main()  
{  
    int testCase;  
    unsigned long long inNum;  
    scanf("%d", &testCase);  
    while (testCase--)  
    {  
        scanf("%lld", &inNum);  
         long double x = inNum*log10(inNum*1.0);  
         x -= unsigned long long(x);  
        printf("%d\n", int(pow(10.0, double(x))));  
    }  
    return 0;  
}  


【思路】

实数可以用科学记数法表示为: a=b*10^c,其中a是任意实数,1<=b<10,C为整数。

此题中,设输入为m,那么 m^m=k*10^n,本题要求解的就是k的整数部分,也就是int(k)

两边取对数:m*log10(m)=n+log10(k)

设x=m*log10(m)=n+log10(k),

由于1<=k<10,所以0<=log10(k)<1

n是x的整数部分。log10(k)是x的小数部分。

换句话说,log10(k)=[x的小数部分]=[x-int(x)]=[m*log10(m)-int(m*log10(m))]

所以int(k)=int(10^log10(k))=int(10^[m*log10(m)-int(m*log10(m))])

【注意事项】

由于m比较大,所以要用到unsign long long,注意输入时的%lld不要出错。


发布了70 篇原创文章 · 获赞 17 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/hwj_wayne/article/details/50849020