20-1-13-和POJ1860思想一样-POJ1125

POJ2240

Arbitrage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 32584 Accepted: 13517

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source

扫描二维码关注公众号,回复: 8858405 查看本文章

Ulm Local 1996

  • 和POJ1860的思想一样, 只要判断是否存在正环回路即可. POJ1860链接如下:
  • POJ1860
  • 将POJ1860的代码改一下就能过
  • 需要注意的是, 下述代码拿c++编译才能过, g++过不了(???)
  • 贴出另一个人写的Floyed的代码Floyed, 短一些
#pragma warning(disable:4996)
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<map>
using namespace std;

const int INF = 0x3f3f3f3f;
const int maxn = 35;

struct Edge {
	int u, v;
	double rate;
	Edge(int _u = 0, int _v = 0, double _rate = 0) :u(_u), v(_v), rate(_rate) {}
};

vector<Edge>e;
double dist[maxn];

map<string, int>mp;		// 名字和顶点序号的对应

bool bellmanFloyed(int n, int s, double v) {
	//初始化条件和bellmanFloyed算法不同
	for (int i = 1; i <= n; i++) {
		dist[i] = 0;
	}
	dist[s] = v;
	for (int i = 1; i < n; i++) {
		bool flag = 0;
		for (int j = 0; j < e.size(); j++) {
			int u = e[j].u;
			int v = e[j].v;
			double rate = e[j].rate;
			//松弛条件和BellmanFloyed算法不同
			if (dist[u] * rate > dist[v]) {
				dist[v] = dist[u] * rate;
				flag = true;
			}
		}
		//如果这一遍没有松弛, 说明没有正环回路, 直接返回
		if (!flag) {
			return false;
		}
	}
	for (int i = 0; i < e.size(); i++) {
		int u = e[i].u;
		int v = e[i].v;
		double rate = e[i].rate;
		if (dist[u] * rate > dist[v]) {
			dist[v] = dist[u] * rate;
			return true;		//发现正环回路
		}
	}
	return false;
}

int main() {
	int kase = 1;
	ios::sync_with_stdio(false); cin.tie(false);
	int n;
	while (scanf("%d", &n) && n) {
		string str;
		mp.clear();
		for (int i = 0; i < n; i++) {
			cin >> str;
			mp[str] = i + 1;
		}
		int m;
		cin >> m;
		string sour, dest;
		double rate;
		e.clear();
		for (int i = 1; i <= m; i++) {
			cin >> sour >> rate >> dest;
			int a = mp[sour];
			int b = mp[dest];
			//边
			e.push_back(Edge(a, b, rate));
		}
		int ans = false;
		ans = bellmanFloyed(n, 1, 100);
		if (ans) {
			cout << "Case " << kase++ << ": Yes" << "\n";
		}
		else {
			cout << "Case " << kase++ << ": No" << "\n";
		}
	}
}
发布了21 篇原创文章 · 获赞 8 · 访问量 2728

猜你喜欢

转载自blog.csdn.net/shen253135371/article/details/103966324