I hate it HDU 1754(单点修改)

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

Input

本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

Output

对于每一次询问操作,在一行里面输出最高成绩。

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Output

5
6
5
9


        
  

Hint

Huge input,the C function scanf() will work better than cin

我看了hdu的dicuss改了很多遍也没找到自己RE在哪里.......4小时了我先把RE的代码放着


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long LL;
const LL MS=200000+5;

int a[MS*4];
int tree[MS*4];



void Pushup(int rt)
{
	tree[rt]=max(tree[rt*2],tree[rt*2+1]);	////在子树节点的模板上变化一下 
}											///子树根存的是一段区间内的最大值,那么直接可以用了 
void Build(int l,int r,int rt)
{
	if(l==r)
	{
		tree[rt]=a[l];return;	
	}
	
	int m=(l+r)/2;
	
	Build(l,m,rt*2);
	Build(m+1,r,rt*2+1);	
	Pushup(rt);
} 
void Update(int l,int r,int rt,int L,int C)
{
	if(l==r)
	{
		tree[rt]=C;return;
	}
	int m=(l+r)/2;
	
	if(L<=m) Update(l,m,rt*2,L,C);
	else     Update(m+1,r,rt*2+1,L,C);  ///应该是else 
	
	Pushup(rt);
	
}

int Query(int l,int r,int rt,int L,int R) 
{
	
	if(L<=l&&r<=R)
	{
		return tree[rt];
	}
	
	int m=(l+r)/2;
	int res=0;

	if(L<=m)   res=max(res,Query(1,m,rt*2,L,R));
	
	
	if(m<R)	  res=max(res,Query(m+1,r,rt*2+1,L,R));
	
	return res;
}
int main(void)
{
	int n,m,k,b;
	while(scanf("%d%d", &n, &m)!=EOF)
	{
			memset(a,0,sizeof(a));memset(tree,0,sizeof(tree));
			
			for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);	
			
			Build(1,n,1);
			
			
			for(int i=1;i<=m;i++)
			{
				
				char s;
				scanf("%c%d%d", &s, &k, &b);
			
				
				
				if(s=='Q')
				printf("%d\n",Query(1,n,1,k,b));	
				if(s=='U')
				Update(1,n,1,k,b);
			}
		
	}
return 0;
}

AC版本:https://blog.csdn.net/zstuyyyyccccbbbb/article/details/104098187

发布了50 篇原创文章 · 获赞 6 · 访问量 1757

猜你喜欢

转载自blog.csdn.net/zstuyyyyccccbbbb/article/details/104095693
今日推荐