UVA1583 Digit Generator【打表】【基础题】

 For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N, we call N a generator of M.

  For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.

  Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.

  You are to write a program to find the smallest generator of the given integer.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N, 1 ≤ N ≤ 100, 000.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print ‘0’.

Sample Input

3

216

121

2005

Sample Output

198

0

1979

题意:如果x加上x的各个数字之和得到y,就说x是y的生成元。给出y,让你求最小的生成元,无解则输出0
AC代码:
#include <stdio.h>  
#include<string.h>
#define N 100000+10 
int a[N];   
int main()  
{  
    int i,T,n,sum;  
    memset(a,0,sizeof(a));  
    for(i=1;i<=100000;i++)  
    {  
        sum=i;  
        int m=i;  
        while(m)  
        {  
            sum += m%10;  
            m /= 10;  
        }  
        if(a[sum]==0||a[sum]>i) 
        	a[sum]=i;  
    }//打表 
    scanf("%d",&T);  
    while(T--)  
    {  
        scanf("%d",&n);  
        printf("%d\n",a[n]);  
    }  
    return 0;  
} 

猜你喜欢

转载自blog.csdn.net/wxd1233/article/details/80343869