poj 1611 并查集

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

题目的大意是SARS在传播,在一所学校里面有好几组学生,他们中有可能有的已经被怀疑感染,其中所有的学生已从0开始被排号,0号已被怀疑感染,问在学校里面有多少人被感染。

下面是WA的结果:WA多次抓狂

#include<iostream>
using namespace std;
int f[30004];
int gf(int c)
{
   while(f[c]!=c)//在此处的代码用在判断有多少个独立的集合还可以,但在这道题中就不合适;
     c=f[c];
return c;
}
void me(int x,int y)
{
    int t1=gf(x);
    int t2=gf(y);
    if(t1!=t2)
        f[t2]=t1;
}
int main()
{
    int t;
     int n;
        int m;
    while(cin>>n>>m&&(n||m))
    {

        for(int i=0;i<n;i++)
            f[i]=i;
        for(int i=1;i<=m;i++)
        {
            int k;
            cin>>k;
            int x,y;
            if(k>=1){
            cin>>x;
            for(int j=1;j<k;j++)
            {
            cin>>y;
            me(x,y);
            }
            }
        }
        int sum=0;
        for(int i=0;i<n;i++)
            if(gf(i)==f[0])
            sum++;
        cout<<sum<<endl;
    }
    return 0;
}

在WA的gf函数如果输入:

10 3

2 1 0

2 9 1

2 2 1

结果是错误的,因为没有对数据进行路径压缩,这样的结果是一棵0->1->9->2这样的单独的树;

但如果是改一下就AC了:

#include<iostream>
using namespace std;
int f[30004];
int gf(int c)
{
    if(f[c]==c)
        return c;
    else
    return f[c]=gf(f[c]);//这样在下面就算sum的时候会对数据路径压缩,将其直接压缩为一个相同的根;
 }
void me(int x,int y)
{
    int t1=gf(x);
    int t2=gf(y);
    if(t1!=t2)
        f[t2]=t1;
}
int main()
{
    int t;
     int n;
        int m;
    while(cin>>n>>m&&(n||m))
    {

        for(int i=0;i<n;i++)
            f[i]=i;
        for(int i=1;i<=m;i++)
        {
            int k;
            cin>>k;
            int x,y;
            if(k>=1){
            cin>>x;
            for(int j=1;j<k;j++)
            {
            cin>>y;
            me(x,y);
            }
            }
        }
        int sum=0;
        for(int i=0;i<n;i++)//不仅遍历,还一旦走到一次根节点,就把这个点到父亲的边改为直接连向根;
            if(gf(i)==f[0])
            sum++;
        cout<<sum<<endl;
    }
    return 0;
}

这样的一个最终树为

0->2;1->2;9->2;

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/80341405