PAT A1153 Decode Registration Card of PAT (25point(s))

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
  • 思路:有点墨迹,就是排序

对于 type 1:
先整体排序,按cmp_stu:分数 -> id
查询时,遍历所有学生,每遍历到相应查询等级就输出

对于 type 2:
输入时就用结构体数组sch[]记录好每个考场的人数和总分数

对于 type 3:
有点麻烦,每次建一个Sch的数组,用来统计查询生日的学生 所在考场的人数,统计完排序输出
【注意】每次都要重置统计数组

  • 坑点:
    Wrong 1:样例1 3 WA ,4 TLE :动态查询必须每次更新 , 只能用scanf和printf输入输出

  • code:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 10010;
struct Stu{
	string id;
	int score;
}stu[maxn];
struct Sch{
	int id, num, total_score;
	Sch(){
		num =  total_score = 0;
	}
}sch[maxn];
bool cmp_stu(Stu a, Stu b){
	return a.score != b.score ? a.score > b.score : a.id < b.id;
}
bool cmp_sch(Sch a, Sch b){
	return a.num != b.num ? a.num > b.num : a.id < b.id;
}
int main(){
	int n, nq;
	scanf("%d %d", &n, &nq);
	for(int i = 0; i < n; ++i){
		cin >> stu[i].id;
		scanf("%d", &stu[i].score);
		int t_site = stoi(stu[i].id.substr(1, 3));
		sch[t_site].num++;
		sch[t_site].total_score += stu[i].score;
	}
	sort(stu, stu + n, cmp_stu);
	for(int i = 1; i <= nq; ++i){
		int type;
		char tmp[15];
		scanf("%d %s", &type, tmp);
		string term = tmp;
		printf("Case %d: %d %s\n", i, type, tmp);
		bool flg = true;
		if(type == 1){
			for(int i = 0; i < n; ++i){
				if(stu[i].id[0] == term[0]){
					printf("%s %d\n", stu[i].id.c_str(), stu[i].score);
					flg = false;
				}
			}	
		}else if(type == 2){
			int t_site = stoi(term);
			if(sch[t_site].num != 0){
				printf("%d %d\n", sch[t_site].num, sch[t_site].total_score);
				flg = false;
			}
		}else{
			vector<Sch> cnt(1000);	//Wrong 1: 样例1 3 WA ,4 TLE 动态查询必须每次更新 , 只能用scanf和printf输入输出 
			for(int i = 0; i < n; ++i){
				if(term == stu[i].id.substr(4, 6)){
					int t_site = stoi(stu[i].id.substr(1, 3));
					cnt[t_site].id = t_site;
					cnt[t_site].num++;				
				}
			}
			sort(cnt.begin(), cnt.end(), cmp_sch);
			for(int i = 0; cnt[i].num > 0 && i < cnt.size(); ++i){
				printf("%d %d\n", cnt[i].id, cnt[i].num);
				flg = false;
			} 
		}
		if(flg) printf("NA\n");
	}
	return 0;
} 
发布了271 篇原创文章 · 获赞 5 · 访问量 6511

猜你喜欢

转载自blog.csdn.net/qq_42347617/article/details/104261960