PAT A1135 Is It A Red-Black Tree (30point(s))

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

· (1) Every node is either red or black.
· (2) The root is black.
· (3) Every leaf (NULL) is black.
· (4) If a node is red, then both its children are black.
· (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
在这里插入图片描述

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line “Yes” if the given tree is a red-black tree, or “No” if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No
  • 思路 1:建树 + 先序遍历判断每个节点是否合法
    条件(1)(3)没用,有没有都不影响吧
    条件(2)输入后可以直接判断
    遍历过程中要判断的只有(4)(5),其中(4)好判断,直接if就可以了
    对于(5),对每个节点递归查询他的,”黑节点高度“:即从这个节点到最深叶子路径上黑的个数

  • code:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 50;
int pre[maxn];
struct node{
	int data;
	node *lc, *rc; 
};
node* NewNode(int x){
	node* r = new node;
	r->data = x;
	r->lc = r->rc = NULL;
	return r;
}
int GetBlack(node* r){
	if(r == NULL) return 1;
	int numL = GetBlack(r->lc);
	int numR = GetBlack(r->rc); 
	if(numL != numR) return -1;
	else return r->data > 0 ? numL + 1 : numL;
	
}
node* Create(int preL, int preR){
	if(preL > preR) return NULL;
	node* r = NewNode(pre[preL]);
	int id = preL + 1;
	while(id < preR && abs(pre[id]) < abs(r->data)) id++;
	int numL = id - preL - 1;
	r->lc = Create(preL + 1, preL + numL);
	r->rc = Create(preL + numL + 1, preR);
	return r;		
}
bool isRBT(node* r){
	if(r->data < 0){	//条件(4) 
		if(r->lc != NULL && r->lc->data < 0) return false; 
		if(r->rc != NULL && r->rc->data < 0) return false;
	}
	if(GetBlack(r) == -1) return false;	//条件(5)
	return true;
}
bool flg;
void PreOrder(node* r){
	if(!isRBT(r)) flg = false;
	if(r->lc != NULL) PreOrder(r->lc);
	if(r->rc != NULL) PreOrder(r->rc);
}
int main(){
	int n;
	scanf("%d", &n);
	for(int i = 0; i < n; ++i){
		int m;
		scanf("%d", &m);
		for(int j = 0; j < m; ++j){
			scanf("%d", &pre[j]);	
		}
		flg = true;		
		if(pre[0] < 0){	//条件(2):样例1 
			flg = false;
		}else{
			node* root = Create(0, m - 1);
			PreOrder(root);
		}
		printf("%s\n", flg ? "Yes" : "No");	
	}
	return 0;
}
  • 思路 2 : 不建树写法

  • code :

#include <bits/stdc++.h>
using namespace std;
const int maxn = 50;
int pre[maxn];

bool flg;
int Create(int preL, int preR){
	if(preL > preR) return 1;
	int r = pre[preL];
	int id = preL + 1;
	while(id <= preR && abs(pre[id]) < abs(r)) id++;
	int numL = id - preL - 1;
	if(r < 0){
		if(preL != preR && pre[preL + 1] < 0)  flg = false;
		if(preL != preR && pre[preL + numL + 1] < 0)  flg = false;
	} 
	int cntL = Create(preL + 1, preL + numL);
	int cntR = Create(preL + numL + 1, preR);
	if(cntL != cntR){
		flg = false;
		return -1;
	}else return r > 0 ? cntL + 1 : cntL;
}
int main(){
	int n, num_v;
	scanf("%d", &n);
	for(int i = 0; i < n; ++i){
		scanf("%d", &num_v);
		for(int j = 0; j < num_v; ++j){
			scanf("%d", &pre[j]);
		}
		flg = true; 
		if(pre[0] < 0) flg = false;
		else Create(0, num_v - 1);
		printf("%s\n", flg ? "Yes" : "No");
	}
	return 0;
}
发布了271 篇原创文章 · 获赞 5 · 访问量 6514

猜你喜欢

转载自blog.csdn.net/qq_42347617/article/details/104226741