PAT A1068 Find More Coins (30point(s))

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10​4​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​4​​, the total number of coins) and M (≤10​2​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.
Output Specification:

For each test case, print in one line the face values V​1​​≤V​2​​≤⋯≤V​k​​ such that V​1​​+V2​​+⋯+V​k​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output “No Solution” instead.

Note: sequence {A[1], A[2], …} is said to be “smaller” than sequence {B[1], B[2], …} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution
  • 思路: 01背包问题,刚接触动态规划,没有搞得很懂,写的思路有点乱

  • code:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 10010;
const int amount = 110;
int dp[maxn][amount], num[maxn];
bool choice[maxn][amount];
vector<int> ans;

int main(){
	int n, aim, tmp;
	scanf("%d %d", &n, &aim);
	for(int i = 1; i <= n; ++i){
		scanf("%d", &num[i]);	
	}
	sort(num + 1, num + n + 1, greater<int>());
	
	for(int i = 1; i <= n; ++i){
		for(int j = num[i]; j <= aim; ++j){
			if(dp[i-1][j-num[i]] + num[i] >= dp[i-1][j]){
				choice[i][j] = 1;
				dp[i][j] = dp[i-1][j-num[i]] + num[i];
			}else{
//				choice[i][j] = 0;
				dp[i][j] = dp[i-1][j];				
			}
		}
	}
	if(dp[n][aim] != aim) printf("No Solution");
	else{
		for(int i = n; i >= 0; --i){
			if(choice[i][aim] == 1){
				ans.push_back(num[i]);	//答案是num[i] 而不是i 
				aim -= num[i];
			}
		}
		for(int i = 0; i < ans.size(); ++i){
			printf("%d", ans[i]);
			if(i < ans.size() - 1) printf(" ");
		}
	}
	return 0; 
}
  • 滚动数组,压缩成一维dp[]

  • code:

#include <bits/stdc++.h>
using namespace std;
const int total_coins = 10010, amount_money = 250;
//int dp[total_coins][amount_money];	// dp[i][v] = 需要付的钱为v时(aim),前i个coin,所能得到的最大价值  
int dp[amount_money];	//用滚动数组压缩为一维 
int value[total_coins], choice[total_coins][amount_money];	//choice[i][v]:需要付的钱为v时(aim),  前i个coin 

int main(){
	int n, aim;
	scanf("%d %d", &n, &aim);
	for(int i = 1; i <= n; ++i) scanf("%d", &value[i]);
	sort(value + 1, value + n + 1, greater<int>());	//Q1 为什么从大往小递推? 
	for(int i = 1; i <= n; ++i){
		for(int j = aim; j >= value[i]; --j){
//dp[i][v] = max(dp[i-1][v], dp[i-1][v-w[i]] + w[i]) -> dp[v] = max(dp[v], dp[v - w[i]] + w[i])
			if(dp[j] <= dp[j - value[i]] + value[i]){	//如果选第i个coin 
				choice[i][j] = 1;
				dp[j] =  dp[j - value[i]] + value[i];
			}
		}
	} 
	if(dp[aim] != aim) printf("No Solution");
	else{
		vector<int> ans;
		for(int i = n; i > 0; --i){
			if(choice[i][aim] == 1){
				ans.push_back(value[i]);
				aim -= value[i];	//回退到上一个状态 
			}
		}
		for(int i = 0; i < ans.size(); ++i){
			printf("%d", ans[i]);
			if(i < ans.size() - 1) printf(" ");
		}
	}
	return 0;
} 
发布了271 篇原创文章 · 获赞 5 · 访问量 6518

猜你喜欢

转载自blog.csdn.net/qq_42347617/article/details/104175681