PAT甲级-1025-PAT Ranking(分数排序+局部排序+全局排序)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input :
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output :
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

思路:

1、先进行局部排序(本考场排名)
2、再进行全局排序(所有考场综合后排名) 将局部排序的结果统统加入全局容器vector中即可
(注意:尽量用scanf,printf格式化输入输出!)

代码如下

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
struct student{
	long long id;
	int score,localR,finalR,loc;
	
}stu[30005];
int cmp(student a,student b){
	if(a.score != b.score) return a.score>b.score;
	return a.id<b.id;
}
int main()
{
	int n,k,num = 0;
	vector<student> final;
	cin>>n;
	for(int i = 0; i < n; i++){
		cin>>k;
		for(int j = 0; j < k; j++){
			scanf("%lld %d", &stu[j].id,&stu[j].score);
			stu[j].loc = i+1;
		}
		sort(stu, stu+k, cmp);//局部排名
		stu[0].localR = 1;
		final.push_back(stu[0]);//易错点! 
		for(int j = 1; j < k; j++){
			stu[j].localR = j+1;
			if(stu[j].score==stu[j-1].score) {
				stu[j].localR=stu[j-1].localR;
			}
			final.push_back(stu[j]);//局部排名变全局排名的关键所在 
		} 
	} 
	sort(final.begin(), final.end(), cmp);//全局排名
	final[0].finalR = 1;
	for(int j = 1; j < final.size(); j++){
		final[j].finalR = j+1;
		if(final[j].score==final[j-1].score){
			final[j].finalR=final[j-1].finalR;
		} 
	}
	cout<<final.size()<<endl;
	for(int i = 0; i < final.size(); i++){
		printf("%013lld %d %d %d\n",final[i].id,final[i].finalR,final[i].loc,final[i].localR);
	}
	return 0;
}
发布了110 篇原创文章 · 获赞 746 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/qq_42437577/article/details/104126825