POJ 2492 A Bug's Life(并查集的变形)

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

题意描述:
给出一个t代表有t组样例,然后再给出一个n和m,n代表的是有n个昆虫,昆虫标号为(1~n),然后再给出m行每行有两个标号代表这两个昆虫可以进行交配,问是否有同性恋的出现。

#include<stdio.h>

int n,f[2100],x[2100],flag;

void inti()
{
	for(int i=1;i<=n;i++)
	{
		f[i]=i;
		x[i]=1;//性别标记初始化
	}
	return ;
}

int getf(int i)
{
	if(f[i]==i)
		return i;
		
	int tmp=f[i];//保留所查到的祖先的子代。
	f[i]=getf(tmp);
	x[i]=(x[i]+x[tmp]+1)%2;//从新判定i的性别
	return f[i];	
}

void merge(int a,int b)
{
	int t1,t2;
	t1=getf(a);
	t2=getf(b);
	if(t1!=t2)
	{
		//printf("%d**%d*\n",t1,t2);
		f[t2]=t1;
		x[t2]=(x[a]+x[b])%2;//从新判定t2的性别
	}
	else
	{
		if((x[a]+x[b])%2==0)//0与0或者是1与1的情况
			flag=1;//标记是否有同性恋
	}
}

int main(void)
{
	int a,b,m,t,t1=1;

	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		flag=0;	
		inti();
		while(m--)
		{ 
			scanf("%d%d",&a,&b);
			merge(a,b);
		}
//		for(int i=1;i<=n;i++)
//			printf("%d ",x[i]);
		printf("Scenario #%d:\n",t1++);
		if(flag==1)
			printf("Suspicious bugs found!\n");
		else
			printf("No suspicious bugs found!\n");
		printf("\n");
	}
	return 0;
	
}


发布了53 篇原创文章 · 获赞 1 · 访问量 1364

猜你喜欢

转载自blog.csdn.net/fgets__/article/details/98766130