PAT甲级 1023 Have Fun with Numbers

PAT甲级 1023 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

字符串就用python,注意两个坑点:
1.不论Yes或No都要输出变化后的数
2.判断两者Yes的条件,首先要长度相同,其次是每个字符的个数相同

s=input()
a=str(int(s)+int(s))
flag=1
if len(a)!=len(s):
    flag=0
for i in range(0,len(s)):
    if s.count(s[i])!=a.count(s[i]):
        flag=0
if flag:
    print("Yes")
    print(a)
else:
    print("No")
    print(a)
发布了288 篇原创文章 · 获赞 14 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/qq_43765333/article/details/104353297