Ubuntu指定版本安装docker-compose

更新apt源:
sudo apt-get update


准备安装目录:
cd /var/lib/dpkg
mv info info.baksudo
mkdir info


先安装pip3:(因为这里用的Ubuntu16.04默认是python3的版本)
sudo apt-get -y install python3-pip 

   
升级pip3
pip3 install --upgrade pip
 #如果带宽延时可选择参数--default-timeout=...

#pip3 install --default-timeout=100 --upgrade pip      


查看升级是否完成:
[email protected]:/var/lib/dpkg# pip -V
pip 19.3.1 from /usr/local/lib/python3.5/dist-packages/pip (python 3.5)


再次更新apt索引:
apt-get update


用pip安装指定的docker-compose 
pip install docker-compose==1.24.0
#同样遇到延时报错可以使用此参数--default-timeout=100


查看docker-compose是否安装完成:
[email protected]:/var/lib/dpkg# docker-compose -v
docker-compose version 1.24.0, build 0aa5906

发布了201 篇原创文章 · 获赞 85 · 访问量 6万+

猜你喜欢

转载自blog.csdn.net/Doudou_Mylove/article/details/103343779

相关文章