1025 反转链表 (25分)

给定一个常数 K 以及一个单链表 L,请编写程序将 L 中每 K 个结点反转。例如:给定 L 为 1→2→3→4→5→6,K 为 3,则输出应该为 3→2→1→6→5→4;如果 K 为 4,则输出应该为 4→3→2→1→5→6,即最后不到 K 个元素不反转。

输入格式:

每个输入包含 1 个测试用例。每个测试用例第 1 行给出第 1 个结点的地址、结点总个数正整数 N (≤105)、以及正整数 K (≤N),即要求反转的子链结点的个数。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。

接下来有 N 行,每行格式为:

Address Data Next

      
    

其中 Address 是结点地址,Data 是该结点保存的整数数据,Next 是下一结点的地址。

输出格式:

对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。

输入样例:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

      
    

输出样例:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

代码

// 1025 反转链表.cpp : 此文件包含 "main" 函数。程序执行将在此处开始并结束。
//

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

struct Node {
    int address;
    int data;
    int next;
};

int data_[1000010];
int next_[1000010];

int main()
{
    int first, n, k, cnt = 0;
    cin >> first >> n >> k;
    int thisaddress, thisdata, thisnext;
    for (int i = 0; i < n; i++) {
        cin >> thisaddress >> thisdata >> thisnext;
        data_[thisaddress] = thisdata;
        next_[thisaddress] = thisnext;
    }
    //从第一个节点开始组装并放入vector容器中
    vector<Node> v;
    while (first != -1) {
        Node node;
        node.address = first;
        node.data = data_[first];
        node.next = next_[first];
        v.push_back(node);
        first = node.next;
    }
    //每k个反转
    for (int i =0; i+3 <= v.size(); i+=k) { //012 345 67
        reverse(v.begin()+i,v.begin()+i+k);
    }
    //打印列表
    cnt = v.size();
    for (int i = 0; i < cnt-1; i++) {
        printf("%05d %d %05d\n",v[i].address,v[i].data,v[i+1].address);
    }
    printf("%05d %d -1", v[cnt - 1].address, v[cnt - 1].data);
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/ericling/p/12340551.html