Critical Links UVA - 796 无向图判桥

一、内容

In a computer network a link L, which interconnects two servers, is considered critical if there are atleast two servers A and B such that all network interconnection paths between A and B pass through L.Removing a critical link generates two disjoint sub–networks such that any twoservers of a sub–networkIt is known thatthe connection links are bi–directional; a server is not directly connected to itself;wo servers are interconnected if they are directly connected or if they are interconnected withthe same server;the network can have stand–alone sub–networks.Write a program that finds all critical links of a given computer network.

Input

The program reads sets of data from a text file. Each data set specifies the structure of a network and
has the format:no of serversserver0 (no of direct connections) connected server . . . connected server. . .serverno of servers (no of direct connections) connected server . . . connected serverThe first line contains a positive integer no of servers(possibly 0) which is the number of networkservers. The next no of servers lines, one for each server in the network, are randomly ordered andshow the way servers are connected. The line corresponding to serverk, 0 ≤ k ≤ no of servers − 1,specifies the number of direct connections of serverk and the servers which are directly connected toserverk. Servers are represented by integers from 0 to no of servers − 1. Input data are correct. Thefirst data set from sample input below corresponds to the network in figure 1, while the second dataset specifies an empty network.

Output

The result of the program is on standard output. For each data set the program prints the number of
critical links and the critical links, one link per line, starting from the beginning of the line, as shown
in the sample output below. The links are listed in ascending order according to their first element.
The output for the data set is followed by an empty line.

Sample Input

8
0 (1) 1
1 (3) 2 0 3
2 (2) 1 3
3 (3) 1 2 4
4 (1) 3
7 (1) 6
6 (1) 7
5 (0)
0

Sample Output

3 critical links
0 - 1
3 - 4
6 - 7
0 critical links

二、思路

  • tarjan求无向图桥
  • 注意去除重边

三、代码

#include <cstdio>
#include <cstring>
#include <vector>
#define P pair<int, int>
#define mk make_pair
#include <algorithm>
using namespace std;
const int N = 1005, M = 2e4 + 5;
struct E {int v, next;} e[M];
int n, u, m, v, len, h[N], num, dfn[N], low[N];
bool brid[M]; vector<P> ans;
void add(int u, int v) {e[++len].v = v; e[len].next = h[u]; h[u] = len;}
void tarjan(int u, int in_edge) {
	dfn[u] = low[u] = ++num;
	for (int j = h[u]; j; j = e[j].next) {
		int v = e[j].v;
		if (!dfn[v]) {
			tarjan(v, j);
			low[u] = min(low[u], low[v]);
			if (dfn[u] < low[v]) brid[j] = brid[j ^ 1] = true; //桥 
		} else if ((j ^ 1) != in_edge) low[u] = min(low[u], dfn[v]);
	}
}
int main() {
	while (~scanf("%d", &n)) {
		ans.clear();
		memset(h, 0, sizeof(h)); len = num = 1;
		memset(dfn, 0, sizeof(dfn));
		memset(brid, false, sizeof(brid));
		for (int i = 0; i < n; i++) {
			scanf("%d (%d)", &u, &m);
			while (m--) {
				scanf("%d", &v); 
				if (u > v) continue; //去重 只允许小的边在前面 
				add(u, v); add(v, u);
			}
		}
		for (int i = 0; i < n; i++) if (!dfn[i]) tarjan(i, 0);
		for (int j = 2; j <= len; j += 2) {
			if (brid[j]) {
				u = e[j].v, v = e[j ^ 1].v; if (u > v) swap(u, v);
				ans.push_back(mk(u, v));
			} 
		}
		sort(ans.begin(), ans.end());
		printf("%d critical links\n", ans.size());
		for (int i = 0; i < ans.size(); i++) printf("%d - %d\n", ans[i].first, ans[i].second);
		puts("");
	}	
	return 0;
}
发布了446 篇原创文章 · 获赞 455 · 访问量 7万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/104430516