Round Numbers//POJ - 3252//数位dp

Round Numbers//POJ - 3252//数位dp


题目

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.
They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.
A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.
Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.
Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input
Line 1: Two space-separated integers, respectively Start and Finish.
Output
Line 1: A single integer that is the count of round numbers in the inclusive range Start… Finish
Sample Input
2 12
Sample Output
6
题意
二进制中0的个数大于等于1,求l到r满足要求的数的个数
链接:https://vjudge.net/contest/349029#problem/L

思路

数位dp,直接储存2进制数位

代码

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
int len,digit[40];
ll dp[40][100];
ll dfs(int pos,int state,bool zero,bool limit){
    if(pos==0){
        if(state<=50) return 1;
        return 0;
    }
    if(!limit&&dp[pos][state]!=-1&&!zero)
        return dp[pos][state];
    int i;
    int up = limit?digit[pos]:9;
    ll ans = 0;
    for(i = 0;i <= up;i ++){
        if(zero&&i==0) {
            ans += dfs(pos-1,state,zero&&i==0,limit&&i==up);
            continue;
        }
        if(i==1) ans += dfs(pos-1,state+1,zero&&i==0,limit&&i==up);
        if(i==0) ans += dfs(pos-1,state-1,zero&&i==0,limit&&i==up);
    }
    if(!limit&&!zero)
        dp[pos][state]= ans;
    return ans;
}
ll cal(ll n){
    len = 0;
    while(n!=0){
        digit[++len] = n%2;
        n /= 2;
    }
    return dfs(len,50,true,true);
}
int main()
{
    memset(dp,-1,sizeof(dp));
    ll l,r;
    scanf("%lld%lld",&l,&r);
    printf("%lld\n",cal(r)-cal(l-1));
    return 0;
}

注意

处理前导0

发布了50 篇原创文章 · 获赞 19 · 访问量 2582

猜你喜欢

转载自blog.csdn.net/salty_fishman/article/details/104246199