HDU 5883 The Best Path 【欧拉路】

                                            The Best Path

                                         Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Problem Description

Alice is planning her travel route in a beautiful valley. In this valley, there are N lakes, and M rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number (a1,a2,...,an ) for each lake. If the path she finds is P0→P1→...→Pt , the lucky number of this trip would be aP0XORaP1XOR...XORaPt . She want to make this number as large as possible. Can you help her?

Input

The first line of input contains an integer t , the number of test cases. t test cases follow.

For each test case, in the first line there are two positive integers N (N≤100000) and M (M≤500000) , as described above. The i -th line of the next N lines contains an integer ai(∀i,0≤ai≤10000) representing the number of the i -th lake.

The i -th line of the next M lines contains two integers ui and vi representing the i -th river between the ui -th lake and vi -th lake. It is possible that ui=vi .

Output

For each test cases, output the largest lucky number. If it dose not have any path, output "Impossible".

Sample Input

2
3 2
3
4
5
1 2
2 3
4 3
1
2
3
4
1 2
2 3
2 4

Sample Output

2

Impossible

【题目链接】 The Best Path

【题意】

有一个图,n个节点,m条边,每个点有一个权值,现在你需要把所有边不重复地都走一遍,求经过点的最大异或和

【思路】

能一次性走完,说明这个图有是欧拉图或半欧拉图(有欧拉回路或通路),那么根据定义可知,欧拉回路要求图中所有点的度数为偶数,欧拉通路要求图中有两个点的度数为奇数,其余均为偶数,据此可以判断出路径是否存在(注意判断图的连通性)

首先对于欧拉通路来说,起点和终点一定是奇度顶点,那么每个点经过的次数为度数除2向上取整(deg[i]+1)/2,由于异或的特殊性质,我们只要把经过次数为奇数的点的权值异或起来即可。

对于欧拉回路来说,起点会多经过一次,我们我们只要枚举起点,跟上面的结果疑惑一下,更新最大值即可

#include <cstdio>
#include <bits/stdc++.h>
#include <cmath>
#include <map>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define mst(a,b) memset((a),(b),sizeof(a))
#define rush() int T;scanf("%d",&T);while(T--)

typedef  long long ll;
const int maxn = 100005;
const ll mod = 1e18+7;
const int INF = 1e9;
const double eps = 1e-6;

int n,m;
int pre[maxn],a[maxn];
int deg[maxn];

int find(int x)
{
    int t,r=x;
    while(x!=pre[x]) x=pre[x];
    while(r!=x)
    {
        t=pre[r];
        pre[r]=x;
        r=t;
    }
    return x;
}

int main()
{
    rush()
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]),pre[i]=i,deg[i]=0;
        for(int i=0;i<m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            deg[x]++,deg[y]++;
            pre[find(x)]=pre[find(y)];
        }
        int num=0;
        int odd=0;
        for(int i=1;i<=n;i++)
        {
            if(find(i)==i) num++;
            if(deg[i]&1) odd++;
        }
        if(num>1||!(odd==0||odd==2))
        {
            puts("Impossible");
            continue;
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            deg[i]=(deg[i]+1)/2;
            if(deg[i]&1) ans^=a[i];
        }
        if(odd==0)
        {
            int tmp=ans;
            for(int i=1;i<=n;i++) ans=max(ans,tmp^a[i]);
        }
        printf("%d\n",ans);
    }
}
发布了259 篇原创文章 · 获赞 100 · 访问量 13万+

猜你喜欢

转载自blog.csdn.net/my_sunshine26/article/details/81262719