LIS longest ascending subsequence sum

Rise longest sequence or the longest common subsequence see previous blog
to hdu 1087 Super Jumping Jumping Jumping!! !
Example:

topic:

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output
4
10
3

Title:

It is to give you any number of groups and each group of n numbers, and the program ends when n is 0. Then give you n values ​​and let you find the longest ascending subsequence sum, such as 1 3 2, the answer is 1 + 3

Ideas:

dp Find the sum of ascending subsequences and then enumerate to find the largest

Code or template:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>

using namespace std;
const int N=1e5+10;
int a[N],dp[N];

int main()
{
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n&&n)
    {
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            cin>>a[i],dp[i]=a[i];//将dp数组初始化为a数组
        int ans=-N;

        for(int i=n-1; i>=1; i--)
        {
            ans=0;  //这里一定要让ans为0 如果和为负数 就处理为0了
            for(int j=i+1; j<=n; j++)
            {
                if(a[j]>a[i])//判断是否是上升的
                    ans=max(ans,dp[j]);
            }
            dp[i]+=ans;//更新dp的值
        }
        ans=-N;
        for(int i=1; i<=n; i++)  //找上升子序列的最大和
        {
            ans=max(dp[i],ans);
        }
        cout<<ans<<endl;

    }
    return 0;
}

Guess you like

Origin blog.csdn.net/Puppet__/article/details/79338584