PAT (Advanced Level) 1013. Battle Over Cities (25) DFS to find connected components

topic link

1013. Battle Over Cities (25)

Time limit:400 ms Memory limit:65536 kB


Problem Descrpition

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.
For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

meaning of the title

Given an undirected graph, after removing a certain point, at least a few edge connections are required to form a connected graph

Problem solving ideas

After removing the points, find the connected components. If there are n connected components, then at least n-1 edges can be used to form a connected graph.

Code

#include "cstdio"
#include "iostream"
#include "cstring"
using namespace std;

const int maxn=1005,maxm=maxn*maxn;
struct Edge
{
    int to,next;
};
Edge e[maxm];
int head[maxn];
bool vis[maxn];
int flag[maxn];
int N,M;
int edge;
int ruined;

void init()
{
    edge=0;
    memset(head,-1,sizeof(head));
}

void addEdge(int u,int v)
{
    e[edge].to=v,e[edge].next=head[u],head[u]=edge++;
}

void DFS(int k)
{
    vis[k]=true;
    for(int i=head[k];i!=-1;i=e[i].next)
    {
        int u=e[i].to;
        if(u!=ruined&&(!vis[u]))
        {
            vis[u]=true;
            DFS(u);
        }
    }
}

int main()
{
    init();
    int n,m,k;
    cin>>n>>m>>k;
    for(int i=0;i<m;i++)
    {
        int u,v;
        cin>>u>>v;
        addEdge(u,v);
        addEdge(v,u);
    }
    while(k--)
    {
        cin>>ruined;
        memset(vis,false,sizeof(vis));
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            if(i==ruined)
                continue;
            if(!vis[i])
            {
                DFS(i);
                cnt++;
            }
        }
        cout<<cnt-1<<endl;
    }
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324841532&siteId=291194637