HDU 2859 Phalanx

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC. 
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position. 
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs. 
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix: 
cbx 
cpb 
zcc
InputThere are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.OutputEach test case output one line, the size of the maximum symmetrical sub- matrix. 
Sample Input
3
abx
cyb
in general
4
frog
cbab
abbc
cacq
0
Sample Output
3
3

Given an n*n character matrix, find the largest antidiagonal symmetric matrix in this matrix. When the length is 1, the matrices are all symmetric matrices ; when the length is 1, the matrices are all symmetric matrices. Initialize dp[i][j]=1. dp from the top right corner to the bottom left corner.

#include<bits/stdc++.h>
using namespace std;
char s[1005][1005];
int dp[1005][1005];
intmain()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        dp[i][j]=1;
        for(int i=0;i<n;i++)
        scanf("%s",s[i]);
        int ans=1;
        for(int i=0;i<n;i++)
        {
            for(int j=n-1;j>=0;j--)
            {
                if(i==0||j==n-1) {dp[i][j]=1;continue;}
                int r=dp[i-1][j+1];
                for(int k=1;k<=r;k++)
                {
                    if(s[i-k][j]==s[i][j+k]) dp[i][j]++;
                    else break;
                }
                ans=max(ans,dp[i][j]);
            }
        }
        printf("%d\n",ans);
    }
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324864188&siteId=291194637