poj2253 frog (shortest distance in a single jump of reachable path)

Frogger

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 55388   Accepted: 17455

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
Portal: Click to open the link
The main idea of ​​the title: A frog wants to go from point 1 to point 2, give you n coordinates, and ask you what is the shortest distance of a single jump for the frog to reach the end point.

Idea: I thought of two points at first, which was very troublesome, and then I thought of dis[] in the djkstra algorithm. Generally, we use this dis to represent the shortest total distance from the starting point set to a certain point. Now we can use dis to represent, from the starting point The shortest distance of a single jump from a point set to a point, so there is

for(int j=1;j<=n;j++){
		if(!vis[j])
		dis[j]=min(dis[j],max(g[p][j],dis[p]));
	}

In fact, it uses three points of triangle, 1, p, and j, and dis[j] is either itself or the one with the largest side of the other two.

The core idea is this, and there are no other pitfalls. Then complete the code.

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<string>
#include<math.h>
#include<cmath>
#include<time.h>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<numeric>
#define ll long long
using namespace std;
const int maxn=210;
const int INF=0x3f3f3f3f;
struct dian {
	double x,y;
} a[maxn];
double g[maxn][maxn];
double dis[maxn];
int vis[maxn],n;
void djks(){
	for(int i=1;i<=n;i++){
		dis[i]=g[1][i];
	}
	memset(vis,0,sizeof(vis));
	vis[1]=1;
	for(int i=1;i<n;i++){
		double minn=INF;
		int p;
		for(int j=1;j<=n;j++){
			if(!vis[j]&&dis[j]<minn){
				p=j;
				minn=dis[j];
			}
		}
		vis[p]=1;
		for(int j=1;j<=n;j++){
			if(!vis[j])
			dis[j]=min(dis[j],max(g[p][j],dis[p]));//核心 用三角形的思路来松弛 
		}
	}
}
int main() {
	int cas=1;
	while(scanf("%d",&n),n) {
		memset(g,INF,sizeof(g));
		for(int i=1; i<=n; i++) {
			scanf("%lf%lf",&a[i].x,&a[i].y);
		}
		for(int i=1; i<=n; i++) {
			for(int j=1; j<=n; j++) {
				double x=a[i].x-a[j].x;
				double y=a[i].y-a[j].y;
				g[i][j]=g[j][i]=pow(x*x+y*y,0.5);
			}
		}
		djks();
		printf("Scenario #%d\n",cas++);
		printf("Frog Distance = %.3f\n\n",dis[2]);
	}
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325908551&siteId=291194637