HDU 1069 Monkey and Banana(dp)

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18357    Accepted Submission(s): 9825


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
 
  
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
 

Sample Output
 
  
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

刚开始做成贪心了,样例最后一组数据过不了。原来是dp,把每个当顶点的高度都算出来,再遍历取最大值,刚开始Case写成了Cast,找了几个小时的错误。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int num;
struct node{
	int x,y,z;	
}mat[300];
int h[300];//h[i]存放以i矩形为顶点的总高度 
int cmp(node a,node b)
{
	if(a.x*a.y==b.x*b.y)
		return a.z>b.z;
	return a.x*a.y>b.x*b.y;//按面积排序 
}
void init(int a,int b,int c)
{//初始化 
	int k=num;
	mat[k].x=a;
	mat[k].y=b;
	mat[k].z=c;
	num++;
}
int main()
{
	int n,a,c,b;
	int ca=1;
	while(~scanf("%d",&n)&&n)
	{
		num=0;//矩形块的总个数 
		int maxn=0;
		memset(h,0,sizeof(h));
		for(int i=0;i<n;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			init(a,b,c);
			init(a,c,b);
			init(b,c,a);
		}
		sort(mat,mat+num,cmp);
		h[0]=mat[0].z;
		for(int i=1;i<num;i++)
		{
			h[i]=mat[i].z;
			for(int j=0;j<i;j++)
			{
				if(mat[i].x<mat[j].x&&mat[i].y<mat[j].y||mat[i].x<mat[j].y&&mat[i].y<mat[j].x)
				{////如果面积大于mat[j]的;那么一定不满足题意!
					if(h[i]<h[j]+mat[i].z)//动态规划 
						h[i]=h[j]+mat[i].z;
				}
			}
		}
		for(int i=0;i<num;i++)
		{//取最大值 
			maxn=max(maxn,h[i]);
		}
		printf("Case %d: maximum height = %d\n",ca++,maxn);
	}
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325939409&siteId=291194637