[POJ - 1458] Common Subsequence (dynamic programming)

Common Subsequence


 Descriptions:

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab

programming contest

abcd mnp

Sample Output

4

2

0

Topic connection: https://vjudge.net/problem/POJ-1458

Subject to the effect

Given two strings, a first length to determine the longest common subsequence: subsequence each string can be found in both the original strings, and the original sequence and each character string consistent in the order

 

Array disposed DP [i] [j], i represents the position of the first string of i, j j denotes the position of the second string, if s1 [i] == s2 [j ] j, then the DP [i] [j] = dp [i- 1] [j-1] +1. otherwise DP [I] [J] = max ( DP [. 1-I] [J], DP [I] [J-. 1] ). can not understand, you can press a sample to draw a table to try to know

 

AC Code

#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
#include <cmath>
#include <deque>
#include <vector>
#include <queue>
#include <string>
#include <cstring>
#include <map>
#include <stack>
#include <set>
#include <sstream>
#define ME0(X) memset((X), 0, sizeof((X)))
using namespace std;
string s1,s2;
int dp[1005][1005];
int main()
{
    while(cin >> s1 >> s2)
    {
        ME0(dp);
        int len1=s1.length();
        int len2=s2.length();
        for(int i=1; i<=len1; i++)
        {
            for(int j=1; j<=len2; j++)
            {
                if(s1[i-1]==s2[j-1])
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                {
                    dp[i][j]=max(dp[i][j-1],dp[i-1][j]);
                }
            }
        }
        cout << dp[len1][len2] << endl;
    }
}

 

 

 

Guess you like

Origin www.cnblogs.com/sky-stars/p/10936527.html