HDUOJ2055:An easy problem

Copyright: qq836678589 https://blog.csdn.net/weixin_43924623/article/details/90903499

An easy problem

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35855 Accepted Submission(s): 23200

Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, … f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.

Output
for each case, you should the result of y+f(x) on a line.

Sample Input
6
R 1
P 2
G 3
r 1
p 2
g 3

Sample Output
19
18
10
-17
-14
-4

#include<iostream>
using namespace std;
int f(char a){
	int b;
	if('Z'>=a&&a>='A'){
		b = a - 'A'+1;
		return b;
	}
	if('z'>=a&&a>='a'){
		b=-a+'a'-1;
		return b;
	}
	return 0;
}
int main(){
	char n;
	int m,i;
	cin>>i;
	while(i--){
		cin>>n>>m;
		cout<<f(n)+m<<endl;
	}
	return 0;
}

Summary: ASK || code a / A were 97 65
AZ: 65 - 90
AZ: 97 - 122

#include<iostream>
using namespace std;
int f(char a){
	int b;
	if('Z'>=a&&a>='A'){
		b = a - 64;
		return b;
	}
	if('z'>=a&&a>='a'){
		b=-a+96;
		return b;
	}
	return 0;
}
int main(){
	char n;
	int m,i;
	cin>>i;
	while(i--){
		cin>>n>>m;
		cout<<f(n)+m<<endl;
	}
	return 0;
}

A out why this can. . .
Nothing wrong, she wanted more. The A / a confused.

Guess you like

Origin blog.csdn.net/weixin_43924623/article/details/90903499