HDU 4585 Shaolin (STL map)

Shaolin

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 4370    Accepted Submission(s): 1883

 

Problem Description

 

Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.

Input

There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.

Output

A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.

Sample Input

3
2 1
3 3
4 2
0

Sample Output

2 1
3 2
4 2

Subject to the effect:

There are n + 1 Shaolin monks, they all have a unique number and value of fighting, when a young man passed all exams and was declared the new Shaolin monks, there will be a battle, as part of the welcome. The new monk must closest to the old monk fighting his battle with a level of combat ratings. If there are two monk who meet this condition, new monks will take the fight rank lower than his monks with him sparring. Now ensure that the input is in ascending order according to the number of input, output requirements of each group in order to fight both the number of new monks after the first output of the output of the old monk. (The first number is a monk, is fighting 1000000000)

Topic analysis:

This title fully reflects the advantages of the map, because when the map is stored in accordance with the keywords stored in ascending order, so if you build map as a key value in accordance with fighting words, find a successor and predecessor of this war is likely to force the value of the new Monk sparring old monk.

Code:

#include<bits/stdc++.h>

using namespace std;
map<int,int>a;
int n,id,level,i;
int main()
{
    while(scanf("%d",&n)!=EOF,n!=0)
    {
        a.clear();
        a[1000000000]=1;
        for(i=1;i<=n;i++)
        {
            cin>>id>>level;
            a[level]=id;
            map<int,int>::iterator p=a.find(level);
            if(p==a.begin())
            printf("%d %d\n",id,(++p)->second);
            else if(p==a.end())
            printf("%d %d\n",id,(--p)->second);
            else if((abs((++p)->first)-(--p)->first)<abs((--p)->first-(++p)->first))
            printf("%d %d\n",id,(++p)->second);
            else
            printf("%d %d\n",id,(--p)->second);
        }
    }
 } 

 

 

 

Guess you like

Origin www.cnblogs.com/dyhaohaoxuexi/p/11318765.html