"Programming algorithms and (ii) the basis of the algorithm" "divide and conquer the sixth week of" dynamic programming

1163:The Triangle

Total time limit: 
1000ms
 
Memory Limit: 
65536kB
description
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Entry
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Export
Your program is to write to standard output. The highest sum is written as an integer.
Sample input
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
Sample Output
30
/ * 
Http://bailian.openjudge.cn/practice/1163/ 
1163: Triangle of The 
recursive solution 2: Digital recursive triangular movable owned by the program memory 
* / 
#include <the iostream> 
#include <algorithm>
 #define MAX 101
 the using  namespace STD;
 int D [MAX] [MAX];
 int SUM [MAX] [MAX];
 int n-;
 int MaxSum ( int I, int J) 
{ 
    IF (! SUM [I] [J] = - . 1 ) / * DESCRIPTION maximum and has counted this path * / 
    { 
        return SUM [I] [J]; 
    } 
    IF (I ==  n-)
    {
        sum[i][j] = D[i][j];
    }
    else
    {
        int x = MaxSum(i + 1, j);
        int y = MaxSum(i + 1, j + 1);
        sum[i][j] = max(x, y) + D[i][j];
    }
    return sum[i][j];
}
int main()
{
    int i, j;
    cin >> n;
    for (i = 0; i < n; i++)
    {
        for (j = 0; j <= i; j++)
        {
            cin >> D[i][j];
            sum[i][j] = -1;
        }
    }
    cout << MaxSum(0, 0) << endl;
    return 0;

}

 

Guess you like

Origin www.cnblogs.com/focus-z/p/11610310.html