C - DFS / BFS POJH - 1979

C - DFS/BFS

POJ - 1979

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set) The end of the input is indicated by a line consisting of two zeros.

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

 

Sample Output

45
59
6
13

 

Subject description:

@ A person from office, Yes tiles. Can go up and down, you can not go # 's. Asked within the scope of his activities how many pieces of tiles can go. (That is, in a place surrounded by #, a total of how many pieces of brick, which is the number of points.)

analysis:

Finish requirements maze, with dfs more convenient. As long as the coordinates marked the beginning of the use of recursion, each recursive step is to take the time, add 1 to the result. Set the end condition, such as a map or go beyond the end of # can be.

Code:

#include<stdio.h> 
char a[30][30];
int N,M;
int res;
int dfs(int y,int x)
{   
    if(y<0||y>M-1||x<0||x>N-1) return 0;
    if(a[y][x]=='#') return 0;
    to [y] [x] = ' G ' ;
    res++;
    for(int dx=-1;dx<=1;dx++)
    {
        int nx=x+dx;
        if(a[y][nx]=='.')
        {
            dfs (and, nx);
        }
    }
    for ( int that = - 1 ; that <= 1 ; these ++ )
    {
        int ny=y+dy;
        if(a[ny][x]=='.')
        {
            dfs (x);
        }
    }
    return 0;
    
}
int main ()
{   
    while(1)
    {
        res=0;
        int p,q;
        scanf("%d %d",&N,&M);
        if(N==0&&M==0) break;
        getchar();
        for(int i=0;i<M;i++)
        {
            for(int j=0;j<N;j++)
            {
                a[i][j]=getchar();
                if(a[i][j]=='@')
                {
                    p=i;
                    q=j;
                }
            }
            getchar();
        }
        dfs(p,q);
        printf("%d\n",res);
    }
    return 0;
}

 

 

Guess you like

Origin www.cnblogs.com/studyshare777/p/12185454.html