1132 Cut Integer (20 minutes)

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No
#include<iostream>
#include<cstring>
#include<vector>

using namespace std;

int main(){
    int n;
    cin >> n;

    for(int i = 0; i < n; i++){
        string s;
        cin >> s;
        int k = s.length() / 2;
        string s1, s2;
        s1 = s.substr(0, k);
        s2 = s.substr(k, k);
        int a, b, c;
        a = stoi(s);
        b = stoi(s1);
        c = stoi(s2);
        if(b == 0 || c == 0){
            printf("No\n");
        }else
        {
            if(a % (b * c) == 0){
            printf("Yes\n");
            }else
            {
            printf("No\n");
            }
        }
        
            
        
        // cout << s1 << " " << s2 << endl;
    }



    return 0;
}

 

发布了38 篇原创文章 · 获赞 0 · 访问量 513

Guess you like

Origin blog.csdn.net/zbchenchanghao/article/details/104092425