PAT Advanced 1048 Find Coins (25) [Hash Hash]

topic

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105,
the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains
N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are
separated by a space.
Output Specification:
For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2
= M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no
solution, output “No Solution” instead.
Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

Topic analysis

  1. int ts [1001], save your entries coin denomination occurrences
  2. int coins [N], the coins stored input
  3. When entering, the face value of the number of occurrences statistics
  4. sort (of coins sorted in ascending order)
  5. Traversing input coins, M- is determined whether the current denomination of coin denomination coin appeared in the input
    • If coins [i] == M-coins [i], M-coins [i] appears twice a minimum denomination
    • If coins [i] <M-coins [i], M-coins [i] denomination least once occurrence
    • If coins [i]> M-coins [i], does not satisfy the condition A1 <= A2

Error-prone point

  1. A1 <= A2 (own bug)
  2. ts should be set to 1001 size, instead of 501 (Subject known: 1 <nominal value of <= 500, but 0 <M <= 1000), because the face value of ts is recorded, it is possible to search for the maximum nominal value of M = 999 (M = 1000 , v1 = 1) where the number of occurrences, if size is set to ts 500, subscripts will be out of range. (Own bug)

Code

Code 01

#include <iostream>
#include <algorithm>
using namespace std;
int main(int argc,char * argv[]) {
    int N,M;
    scanf("%d %d",&N,&M);
    int coins[N]= {0};
    int values[1001]= {0};
    for(int i=0; i<N; i++) {
        scanf("%d",&coins[i]);
        values[coins[i]]++;
    }
    sort(coins,coins+N);
    int i;
    for(i=0; i<N; i++) {
        if((coins[i]==M-coins[i]&&values[coins[i]]>=2)
                ||(coins[i]<M-coins[i]&&values[M-coins[i]]>=1)) { //!= 第二个点错误 
            printf("%d %d", coins[i], M-coins[i]);
            break;
        }
    }
    if(i==N)printf("No Solution");
    return 0;
}


Guess you like

Origin www.cnblogs.com/houzm/p/12238561.html