1028 List Sorting (25分)

topic

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N ( 1 0 5 ) N(\le10^5) and C C , where N N is the number of records and C C is the column that you are supposed to sort the records with. Then N N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N N lines. That is, if C = 1 C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

Subject to the effect

Excel spreadsheet sort of analog functions, input student information includes number, name, score, to be able to sort the information based on these three

Problem-solving skills

The establishment of a structure problem save student information, student information is stored in the same time vectorusing the sort sort()function, which is why the use vectorof reasons, vectorthe array suitable for sort()sorting, subject to note there are two places:

  1. When the name is the same, according to the idsmall to large order;
  2. When the results are the same, according to the idlarge order small;

Code

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;

struct student{
    int id;
    char name[9];
    int grade;
};

bool cmp1(student s1, student s2){
    return s1.id < s2.id;
}

bool cmp2(student s1, student s2){
    int temp = strcmp(s1.name, s2.name);
    if(temp < 0)
        return true;
    else if(temp == 0)
        return s1.id < s2.id;
    else
        return false;
}

bool cmp3(student s1, student s2){
    return s1.grade == s2.grade ? s1.id < s2.id:s1.grade < s2.grade;
}

int main(){
    int n, c;
    scanf("%d%d", &n, &c);
    vector<student> s(n);
    for(int i=0; i<n; i++)
        scanf("%d%s%d", &s[i].id, &s[i].name, &s[i].grade);
    if(c == 1)
        sort(s.begin(), s.end(), cmp1);
    else if(c == 2)
        sort(s.begin(), s.end(), cmp2);
    else
        sort(s.begin(), s.end(), cmp3);
    for(int i=0; i<n; i++)
        printf("%06d %s %d\n", s[i].id, s[i].name, s[i].grade);
    return 0;
}

Published 37 original articles · won praise 30 · views 10000 +

Guess you like

Origin blog.csdn.net/qq_40941722/article/details/104269595