Post Office POJ - 1160(DP)

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates.

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum.

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office.
Input
Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.
Output
The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.
Sample Input
10 5
1 2 3 6 7 9 11 22 44 50
Sample Output
9

Meaning of the title:
the n-villages, p villages put the post office. Each village to find the nearest post office and distance

Ideas:
First conclusion: Suppose n villages put a post office, then in the middle of the best.

And n is assumed villages, the intermediate is (1 + n) / 2. Then for n + optimum one village:
Suppose n is odd, then (1 + n) / 2 = (1 + 1 + n) / 2
is assumed that n is even, then (1 + n) / 2 + 1 = (1 + 1 + n) / 2
and the case (1 + n) / 2 and (1 + n) / 2 + 1 n can be regarded as a midpoint villages.
It concluded that n + n villages and an optimum villages may be the same.

Definition of DIS [i] [j] i to put a post office within the minimum distance j and
F [i] [j] j put the post office for the first minimum distance and villages i.
f [i] [j] = min {f [k] [j - 1] = dis [k + 1] [i]}

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int f[305][305];
int dis[305][305];
int a[305];
int n,p;

void init()
{
    for(int i = 1;i <= n;i++)
    {
        for(int j = i + 1;j <= n;j++)
        {
            dis[i][j] = dis[i][j - 1] + a[j] - a[(i + j) >> 1];
        }
    }
}

void DP()
{
    memset(f,0x3f,sizeof(f));
    for(int i = 1;i <= p;i++)f[i][i] = 0;
    for(int i = 1;i <= n;i++)f[i][1] = dis[1][i];
    for(int j = 2;j <= p;j++)
    {
        for(int i = j + 1;i <= n;i++)
        {
            for(int k = j - 1;k < i;k++)
            {
                f[i][j] = min(f[i][j],f[k][j - 1] + dis[k + 1][i]);
            }
        }
    }
}

int main()
{
    scanf("%d%d",&n,&p);
    for(int i = 1;i <= n;i++)scanf("%d",&a[i]);
    init();
    DP();
    printf("%d\n",f[n][p]);
    return 0;
}

Published 676 original articles · won praise 18 · views 30000 +

Guess you like

Origin blog.csdn.net/tomjobs/article/details/104210483