PAT Advanced 1076 Forwards on Weibo (30) [FIG traversal, BFS, DFS]

topic

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:
M[i] user_list[i]
where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space. Then finally a positive K is given, followed by K UserID’s for query.
Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.
Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5

Topic analysis

After a user send a micro-blog, which forwards once fans, which fan is a fan for forwarding all networks view of a known, find the maximum number of forwarding, the number of layers indirect fans <= L

Problem-solving ideas

Ideas 01 (BFS optimal)

BFS, the structure defining the pole, the definition of the attribute record level in the hierarchical access node vertex, the stop accessing over L

Ideas 02 (DFS)

After the depth-first search, using recursion depth parameter record levels, exceeding L stop access

Question: DFS in the visited node marked as visited, lose some path , assuming no sample in the path 6-3-5-7, 6-3-1-4 after the visit, and then access 6-3-4- 5, because visited 4 mark, so this path is not accessible, node 5 will not be counted

solution: use a record level at the node array is accessed, if is accessed again, to see if the current level is less than level array before being accessed hierarchy can be accessed if less than

Code

Code 01 (BFS optimal)

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
const int maxn=1010;
vector<int> g[maxn]; //粉丝列表
int L;
struct node {
    int v;
    int layer;
//  node () {}
//  node(int _v):v(_v) {}
} ;
int bfs(int v) {
    int cnt=0;
    queue<node> q;
    q.push({v,0});
    int vis[maxn]= {0};
    vis[v]=1;
    while(!q.empty()) {
        node now = q.front();
        q.pop();
        for(int i=0; i<g[now.v].size(); i++) {
            if(now.layer<L&&vis[g[now.v][i]]==0) {
                q.push({g[now.v][i],now.layer+1});
                cnt++;
                vis[g[now.v][i]]=1;
            }
        }
    }
    return cnt;
}
int main(int argc,char * argv[]) {
    int n,m,z,t,y;
    scanf("%d %d",&n,&L);
    for(int i=1; i<=n; i++) {
        scanf("%d",&m);
        for(int j=0; j<m; j++) {
            scanf("%d",&z);
            g[z].push_back(i);
        }
    }
    scanf("%d",&t);//查询次数
    for(int i=0; i<t; i++) {
        scanf("%d",&y);
        printf("%d\n",bfs(y));//广度搜素
    }

    return 0;
}

Code 02(DFS)

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
const int maxn=1010;
vector<int> g[maxn]; //粉丝列表
int L,vis[maxn],level[maxn];
void dfs(int v, int depth) {
    if(depth>L)return;
    vis[v]=1;
    level[v]=depth;
    for(int i=0; i<g[v].size(); i++) {
        if(vis[g[v][i]]!=1||depth+1<level[g[v][i]])
            dfs(g[v][i],depth+1);
    }
}
int main(int argc,char * argv[]) {
    int n,m,z,t,y;
    scanf("%d %d",&n,&L);
    for(int i=1; i<=n; i++) {
        scanf("%d",&m);
        for(int j=0; j<m; j++) {
            scanf("%d",&z);
            g[z].push_back(i);
        }
    }
    scanf("%d",&t);//查询次数
    for(int i=0; i<t; i++) {
        scanf("%d",&y);
        fill(vis,vis+maxn,0);
        int cnt=0;
        dfs(y,0);//深度搜素
        for(int j=1; j<=n; j++) {
            if(vis[j]==1)cnt++;
        }
        printf("%d\n",cnt-1);
    }

    return 0;
}


Guess you like

Origin www.cnblogs.com/houzm/p/12353420.html