PAT A1048 Find Coins (25分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805432256675840

题目描述
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10^​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

输入
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10^​5​​ , the total number of coins) and M (≤10^​3​​ , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

输出
For each test case, print in one line the two face values V
​1​​ and V​2​​ (separated by a space) such that V​1​​ +V​2
​​ =M and V​1​​ ≤V​2​​ . If such a solution is not unique, output the one with the smallest V​1​​ . If there is no solution, output No Solution instead.

样例输入
8 15
1 2 8 7 2 4 11 15

样例输出
4 11

代码

#include <cstdio>
#include <algorithm>
using namespace std;

int main() {
	int n, m, a[100010];
	bool flag = false;
	scanf("%d%d", &n, &m);
	for(int i = 0; i < n; i++)
		scanf("%d", &a[i]);
	sort(a, a + n);
	for(int i = 0 , j = n - 1; i < j;) {
		if(a[i] + a[j] == m) {
			printf("%d %d\n", a[i], a[j]);
			flag = true;
			break;
		}
		if(a[i] + a[j] < m)
			i++;
		if(a[i] + a[j] > m)
			j--;
	}
	if(flag == false)
		printf("No Solution\n");
	return 0;
}
发布了288 篇原创文章 · 获赞 12 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/104669787