PAT (Advanced Level) Practice A1048 Find Coins (25 分)(C++)(甲级)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86489121

1048 Find Coins (25 分)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5 , the total number of coins) and M (≤103 , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1 and V2 (separated by a space) such that V1+V​2=M and V​1​​ ≤V2. If such a solution is not unique, output the one with the smallest V​1 . If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15
Sample Output 1:

4 11
Sample Input 2:

7 14
1 8 7 2 4 11 15
Sample Output 2:

No Solution


using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>


bool cmp(int a, int b)
{
    return a<b;
}

int C[100010] = {0};//存放每个输入的硬币面额

int main()
{
    int N, M;
    scanf("%d %d", &N, &M);
    for(int i=0; i<N; i++) scanf("%d", &C[i]);
    sort(C, C+N, cmp);//从小到大排序
    int i=0, j=N-1;
    while(C[i]+C[j] != M && i<j)//遍历扫描看是否有满足C[i]+C[j] == M && i<j存在
    {
        while(C[i]+C[j] < M) i++;//比M小则用一个面额更大的去试
        while(C[i]+C[j] > M) j--;//反之则用面额更小的去试
    }
    if(C[i]+C[j] == M && i<j) printf("%d %d", C[i], C[j]);//有满足条件的则输出
    else printf("No Solution");//否则No Solution
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86489121