PAT (Advanced Level) Practice A1055 The World's Richest (25 分) (C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/86426802

1055 The World’s Richest (25 分)
Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10
​5
​​ ) - the total number of people, and K (≤10
​3
​​ ) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10
​6
​​ ,10
​6
​​ ]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50
Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None


using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>


typedef struct Richest//大佬大佬
{
    char Name[10];
    int Age;
    int Net_Worth;
}Richest;

Richest R[100010] = {0};

bool cmp(Richest A, Richest B)
{
    if(A.Net_Worth != B.Net_Worth) return A.Net_Worth > B.Net_Worth;//先按财富的递减顺序排列
    if(A.Age != B.Age) return A.Age < B.Age;//按年纪的递增顺序排列
    return strcmp(A.Name, B.Name) < 0;//按名字的字典顺序排列
}

int main()
{
    int N = 0, K = 0;
    scanf("%d %d", &N, &K);
    for(int i=0; i<N; i++)
    {
        scanf("%s %d %d", R[i].Name, &R[i].Age, &R[i].Net_Worth);
    }
    sort(R, R+N, cmp);
    int X = 0, Amin = 0, Amax = 0;
    for(int i=1; i<=K; i++)
    {
        scanf("%d %d %d", &X, &Amin, &Amax);
        int cnt = 0;
        printf("Case #%d:\n", i);//控制输出格式
        for(int j=0; j<N && cnt<X; j++)//注意cnt<X
        {
            if(R[j].Age >= Amin && R[j].Age <= Amax)//在年龄区间则输出
            {
                printf("%s %d %d\n", R[j].Name, R[j].Age, R[j].Net_Worth);
                cnt++;//计数
            }
        }
        if(!cnt) printf("None\n");//该区间内无人
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86426802