PAT A1055 The World's Richest (25)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10^5) - the total number of people, and K (≤10^3) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10^6 ,10^6]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

解题思路

数据依照财富水平排序。
由于题目给定了最大输出M为100,就可以对数据预处理,将每个年龄财富水平前100另外保存,因为100名之后的人永远不会输出。
(考虑这种情况,共有200人,其中199人年龄39,另一个年龄50,其中198个39和另一个50的财富水平相当,余下的39财富较低,有可能会有40~50年龄的查询,这时就要对每个年龄都记录其前100名,而不是总共记录100名。)
查询时,查询第二个数组,此时进行遍历即可。

AC代码

// n个人中,找出给定年龄范围内的M个最富有的人 
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxn = 100010, maxk = 1010; 
int Age[220] = {0};
struct  person{
    char name[9];
    int age, worth;
}p[maxn], p1[110];
bool cmp(person a, person b){
    if(a.worth != b.worth)  return a.worth > b.worth;
    else if(a.age != b.age) return a.age < b.age;
    else                    return strcmp(a.name, b.name) < 0;
}

int main() {
    int n, k;
    scanf("%d%d", &n, &k); 

    for(int i = 0; i < n; i++){
        scanf("%s%d%d", p[i].name, &p[i].age, &p[i].worth);
    }
    sort(p, p+n, cmp);
    int validnum = 0;
    for(int i = 0; i < n; i++){
        if(Age[p[i].age] < 100){
            Age[p[i].age]++;
            p1[validnum++] = p[i];
        }
    }

    int num = 0, low = 0, high = 0;
    for(int i = 1; i <= k; i++){
        scanf("%d%d%d", &num, &low, &high);
        printf("Case #%d:\n", i);
        int printnum = 0;
        for(int j = 0; j < validnum && printnum < num; j++){
            if(p1[j].age >= low && p1[j].age <= high){
                printf("%s %d %d\n", p1[j].name, p1[j].age, p1[j].worth);
                printnum++;
            }
        }
        if(printnum == 0)
            printf("None\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/fried123123/article/details/81543058